CVE-2023-25957
Təsvir
Mendix SAML (Mendix 7 ilə uyğun) (Bütün versiyalar >= V1.16.4 < V1.17.3), Mendix SAML (Mendix 8 ilə uyğun) (Bütün versiyalar >= V2.2.0 < V2.3.0), Mendix SAML (Mendix 9 ən son uyğun, New Track) (Bütün versiyalar >= V3.1.9 < V3.3.1), Mendix SAML (Mendix 9 ən son uyğun, Upgrade Track) (Bütün versiyalar >= V3.1.8 < V3.3.0), Mendix SAML (Mendix 9.6 ilə uyğun, New Track) (Bütün versiyalar >= V3.1.9 < V3.2.7), Mendix SAML (Mendix 9.6 ilə uyğun, Upgrade Track) (Bütün versiyalar >= V3.1.8 < V3.2.6) modulunda zəiflik aşkar edilmişdir. Modulun təsirlənmiş versiyaları SAML təsdiqlərini kifayət qədər yoxlamır. Bu, autentifikasiyadan keçməmiş uzaqdan təcavüzkarlara autentifikasiyadan yan keçməyə və tətbiqə giriş əldə etməyə imkan verə bilər. Uyğunluq səbəblərindən düzəliş versiyaları bu problemi hələ də ehtiva edir, lakin yalnız tövsiyə olunan standart konfiqurasiya seçimi `'Use Encryption'` deaktiv edildikdə.
Necə düzəltmək olar
- mendix saml1.17.2, 2.2.3, 3.2.5 və ya daha yeni versiya
Təsirlənən məhsullar
| Məhsul | Təsirlənən versiyalar | Düzəldildiyi versiya |
|---|---|---|
| mendix saml | 1.16.4 ≤ v < 1.17.2, 2.2.0 ≤ v < 2.2.3, 3.1.9 ≤ v < 3.2.5 | 1.17.2, 2.2.3, 3.2.5 |
Versiyanızı yoxlayın
Məhsulu seçin və istifadə etdiyiniz versiyanı yazın; versiyanın təsirlənən aralıqda olub-olmadığını görün.
Attack Surface Management
Domenlərinizə bağlı aktivləri, onlarda işləyən texnologiyaları və məlum zəiflikləri bir siyahıda görün.