CVE-2025-8715

Yüksək

Təsvir

PostgreSQL-dəki pg_dump komponentində yeni sətir simvollarının düzgün neytrallaşdırılmaması, orijinal server istifadəçisinə xüsusi hazırlanmış obyekt adı daxilində psql meta-əmrləri vasitəsilə bərpa zamanı kodu icra etmək üçün ixtiyari kod inyeksiya etməyə imkan verir; bu kod, dump faylını bərpa edən psql-i işlədən müştəri əməliyyat sistemi hesabı səviyyəsində icra olunur. Eyni hücumlar bərpa hədəfi olan serverdə superistifadəçi kimi SQL inyeksiyasına nail olmağa imkan verir. pg_dumpall, pg_restore və pg_upgrade də bundan təsirlənib. PostgreSQL 17.6, 16.10, 15.14, 14.19 və 13.22 versiyalarından əvvəlki versiyalar təsirlənmişdir. 11.20-dən əvvəlki versiyalar təsirlənməyib. CVE-2012-0868 bu növ problemi həll etmişdi, lakin 11.20 versiyasında bu problem yenidən ortaya çıxmışdır.

CiddilikYüksək
CVSS8.8
İstismar ehtimalı—
MəhsulPostgreSQL
Dərc14 avq 2025
İlk görülmə14 avq 2025
Zəiflik növüCWE-93CWE-93

Necə düzəltmək olar

Yeniləyin
  • PostgreSQL17.6, 16.10, 15.14, 14.19, 13.22 və ya daha yeni versiya

Təsirlənən məhsullar

MəhsulTəsirlənən versiyalarDüzəldildiyi versiya
PostgreSQL17 ≤ v < 17.6, 16 ≤ v < 16.10, 15 ≤ v < 15.14, 14 ≤ v < 14.19, 11.20 ≤ v < 13.2217.6, 16.10, 15.14, 14.19, 13.22

Versiyanızı yoxlayın

Məhsulu seçin və istifadə etdiyiniz versiyanı yazın; versiyanın təsirlənən aralıqda olub-olmadığını görün.

Intelligence 360 paketində

Attack Surface Management

Domenlərinizə bağlı aktivləri, onlarda işləyən texnologiyaları və məlum zəiflikləri bir siyahıda görün.

CVE-2025-8715 · PostgreSQL · Dark Radar