CVE-2026-55758

Orta

Təsvir

CC: Tweaked, Minecraft üçün proqramlaşdırıla bilən kompüterlər, turtles və digər funksiyalar əlavə edən bir moddur. 1.120.0 versiyasından əvvəl, projects/core/src/main/java/dan200/computercraft/core/apis/http/options/AddressPredicate.java faylındakı SSRF müdafiəsi RFC 6052 64:ff9b::/96 NAT64 prefiksini bloklayır, lakin RFC 8215 64:ff9b:1::/48 lokal istifadə prefiksinə məhəl qoymur. RFC 8215 NAT64 istifadə edən dual-stack serverdə, Lua kodu icra edə bilən autentifikasiya olunmamış istifadəçi, PrivatePattern.matches() funksiyası xəritələnmiş IPv6 ünvanını şəxsi (private) kimi təsnif etmədiyi üçün loopback, RFC 1918, bulud metadata və ya daxili API son nöqtələrinə çatmaq üçün 64:ff9b:1::/48 altında olan ünvanla http.request və ya http.websocket-dən istifadə edə bilər. Bu problem 1.120.0 versiyasında düzəldilib.

CiddilikOrta
CVSS6.9
İstismar ehtimalı—
MəhsulCC-Tweaked
Dərc27 avq 2026
İlk görülmə27 avq 2026

Necə düzəltmək olar

Mənbələrdə bu zəiflik üçün düzəldilmiş versiya və ya yamaq keçidi yoxdur.

Təsirlənən məhsullar

MəhsulTəsirlənən versiyalarDüzəldildiyi versiya
cc-tweaked CC-Tweaked< 1.120.0—

Versiyanızı yoxlayın

Məhsulu seçin və istifadə etdiyiniz versiyanı yazın; versiyanın təsirlənən aralıqda olub-olmadığını görün.

Intelligence 360 paketində

Attack Surface Management

Domenlərinizə bağlı aktivləri, onlarda işləyən texnologiyaları və məlum zəiflikləri bir siyahıda görün.

CVE-2026-55758 · CC-Tweaked · Dark Radar