CVE-2026-9256

Yüksək

Təsvir

NGINX Plus və NGINX Open Source versiyalarının ngx_http_rewrite_module modulunda zəiflik mövcuddur. Bu zəiflik, rewrite direktivi fərqli və üst-üstə düşən Perl-Compatible Regular Expression (PCRE) tutmalarına malik reqeks naxışından (məsələn, ^/((.*))$) və yönləndirmə və ya arqumentlər kontekstində bu cür çoxlu tutmalara istinad edən əvəzləmə sətirindən (məsələn, $1$2) istifadə etdikdə yaranır. Autentifikasiya olunmamış hücumçu, öz nəzarətindən kənar şərtlər daxilində, xüsusi hazırlanmış HTTP sorğuları göndərməklə bu zəiflikdən istifadə edə bilər. Bu, NGINX işçi prosesində heap bufer daşmasına səbəb ola və onun yenidən başladılmasına gətirib çıxara bilər. Əlavə olaraq, hücumçular Address Space Layout Randomization (ASLR) funksiyasının söndürüldüyü sistemlərdə və ya ASLR-ı yan keçə bildikləri hallarda kod icra edə bilərlər. Qeyd: Texniki dəstəyin sonlandığı (End of Technical Support - EoTS) proqram təminatı versiyaları qiymətləndirilməmişdir.

CiddilikYüksək
CVSS8.1
İstismar ehtimalı—
MəhsulF5 Nginx Open Source
Dərc22 may 2026
İlk görülmə22 may 2026
Zəiflik növüCWE-122CWE-122

Necə düzəltmək olar

Yeniləyin
  • f5 nginx_open_source1.30.2 və ya daha yeni versiya
  • f5 nginx_plusr36 və ya daha yeni versiya
  • f5 nginx_gateway_fabric2.6.2 və ya daha yeni versiya
  • f5 nginx_ingress_controller5.4.3 və ya daha yeni versiya
  • f5 nginx_instance_manager2.22.1 və ya daha yeni versiya
  • redhat update_infrastructure5.2 və ya daha yeni versiya

Təsirlənən məhsullar

MəhsulTəsirlənən versiyalarDüzəldildiyi versiya
f5 nginx_open_source0.1.17 ≤ v ≤ 0.9.7, 1.0.0 ≤ v < 1.30.2, 1.31.01.30.2
f5 nginx_plusr33 ≤ v < r36, 37.0.0.1, r32, r36r36
f5 dos4.3.0 ≤ v ≤ 4.7.0, 4.9.0—
f5 nginx_gateway_fabric1.3.0 ≤ v ≤ 1.6.2, 2.0.0 ≤ v < 2.6.22.6.2
f5 nginx_ingress_controller3.5.0 ≤ v ≤ 3.7.2, 4.0.0 ≤ v ≤ 4.0.1, 5.0.0 ≤ v < 5.4.35.4.3
f5 nginx_instance_manager2.17.0 ≤ v < 2.22.12.22.1
f5 waf4.10.0 ≤ v ≤ 4.16.0, 5.2.0 ≤ v ≤ 5.8.0, 5.9.0 ≤ v ≤ 5.13.0—
redhat discoveryAralıq göstərilməyib—
redhat hardened_imagesAralıq göstərilməyib—
redhat update_infrastructure5.0 ≤ v < 5.25.2
debian debian_linux11.0—
redhat enterprise_linux8.0, 9.0, 10.0—

Versiyanızı yoxlayın

Məhsulu seçin və istifadə etdiyiniz versiyanı yazın; versiyanın təsirlənən aralıqda olub-olmadığını görün.

Intelligence 360 paketində

Attack Surface Management

Domenlərinizə bağlı aktivləri, onlarda işləyən texnologiyaları və məlum zəiflikləri bir siyahıda görün.

CVE-2026-9256 · F5 Nginx Open Source · Dark Radar