CVE-2018-1000079
Açıklama
RubyGems sürümü Ruby 2.2 serisi: 2.2.9 ve öncesi, Ruby 2.3 serisi: 2.3.6 ve öncesi, Ruby 2.4 serisi: 2.4.3 ve öncesi, Ruby 2.5 serisi: 2.5.0 ve öncesi, trunk revizyon 62422 öncesi, gem kurulumunda, gem'in kurulum sırasında rastgele dosya sistemi konumlarına yazabilmesine yol açabilen bir Dizin Geçişi zafiyeti içerir. Bu saldırının, mağdurun kötü niyetli bir gem kurması yoluyla istismar edilebilir olduğu görünmektedir. Bu zafiyetin 2.7.6 sürümünde düzeltildiği görünmektedir.
Nasıl düzeltilir
- rubygems-update2.7.6 ya da sonraki bir sürüm
- org.jruby:jruby-stdlib9.1.16.0 ya da sonraki bir sürüm
- debian.org/security/2018/dsa-4219
- usn.ubuntu.com/3621-1/
- access.redhat.com/errata/RHSA-2018:3729
- access.redhat.com/errata/RHSA-2018:3730
- access.redhat.com/errata/RHSA-2018:3731
- debian.org/security/2018/dsa-4259
- access.redhat.com/errata/RHSA-2019:2028
- access.redhat.com/errata/RHSA-2020:0542
- access.redhat.com/errata/RHSA-2020:0591
- access.redhat.com/errata/RHSA-2020:0663
Etkilenen ürünler
| Ürün | Etkilenen sürümler | Düzeltildiği sürüm |
|---|---|---|
| rubygems rubygems | v ≤ 2.2.9, v ≤ 2.3.6, v ≤ 2.4.3, v ≤ 2.5.0 | — |
| rubygems-updateRubyGems | v < 2.7.6 | 2.7.6 |
| org.jruby:jruby-stdlibMaven | v < 9.1.16.0 | 9.1.16.0 |
Sürümünüzü kontrol edin
Ürünü seçin ve kullandığınız sürümü yazın; sürümün etkilenen aralıkta olup olmadığını görün.
Attack Surface Management
Alan adlarınıza bağlı varlıkları, bu varlıklarda çalışan teknolojileri ve bilinen zafiyetleri tek listede görün.