CVE-2023-29129
Açıklama
Mendix SAML (Mendix 7 compatible) (Tüm versiyonlar >= V1.17.3 < V1.18.0), Mendix SAML (Mendix 7 compatible) (Tüm versiyonlar >= V1.16.4 < V1.17.3), Mendix SAML (Mendix 8 compatible) (Tüm versiyonlar >= V2.3.0 < V2.4.0), Mendix SAML (Mendix 8 compatible) (Tüm versiyonlar >= V2.2.0 < V2.3.0), Mendix SAML (Mendix 9 latest compatible, New Track) (Tüm versiyonlar >= V3.3.1 < V3.6.1), Mendix SAML (Mendix 9 latest compatible, New Track) (Tüm versiyonlar >= V3.1.9 < V3.3.1), Mendix SAML (Mendix 9 latest compatible, Upgrade Track) (Tüm versiyonlar >= V3.3.0 < V3.6.0), Mendix SAML (Mendix 9 latest compatible, Upgrade Track) (Tüm versiyonlar >= V3.1.8 < V3.3.0), Mendix SAML (Mendix 9.12/9.18 compatible, New Track) (Tüm versiyonlar >= V3.3.1 < V3.3.15), Mendix SAML (Mendix 9.12/9.18 compatible, Upgrade Track) (Tüm versiyonlar >= V3.3.0 < V3.3.14), Mendix SAML (Mendix 9.6 compatible, New Track) (Tüm versiyonlar >= V3.1.9 < V3.2.7), Mendix SAML (Mendix 9.6 compatible, Upgrade Track) (Tüm versiyonlar >= V3.1.8 < V3.2.6) ürünlerinde bir güvenlik açığı tespit edilmiştir. Modülün etkilenen versiyonları, SAML iddialarını (assertions) yetersiz şekilde doğrulamaktadır. Bu durum, kimlik doğrulaması yapmamış uzaktaki saldırganların kimlik doğrulama atlatmasına ve uygulamaya erişim sağlamasına izin verebilir. Bu CVE girişi, belirli bir varsayılan olmayan yapılandırmadaki CVE-2023-25957 için yapılan eksik düzeltmeyi tanımlamaktadır.
Nasıl düzeltilir
- mendix saml1.18.0, 2.4.0, 3.6.1 ya da sonraki bir sürüm
Etkilenen ürünler
| Ürün | Etkilenen sürümler | Düzeltildiği sürüm |
|---|---|---|
| mendix saml | 1.16.4 ≤ v < 1.18.0, 2.2.0 ≤ v < 2.4.0, 3.1.8 ≤ v < 3.6.1 | 1.18.0, 2.4.0, 3.6.1 |
Sürümünüzü kontrol edin
Ürünü seçin ve kullandığınız sürümü yazın; sürümün etkilenen aralıkta olup olmadığını görün.
Attack Surface Management
Alan adlarınıza bağlı varlıkları, bu varlıklarda çalışan teknolojileri ve bilinen zafiyetleri tek listede görün.