CVE-2025-59302
Açıklama
Apache CloudStack'te yalnızca yöneticilerin erişebildiği aşağıdaki API'lerde hatalı kod oluşturma kontrolü ('Code Injection') zafiyeti tespit edilmiştir. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage Bu sorun Apache CloudStack'in 4.18.0 ile 4.20.2 arasındaki ve 4.21.0 ile 4.22.0 arasındaki sürümlerini etkilemektedir. Kullanıcıların düzeltmeyi içeren 4.20.2 veya 4.22.0 sürümlerine yükseltme yapmaları önerilir. Düzeltme, yöneticilerin bu API'lerdeki JavaScript ifadelerinin yorumlanmasını kontrol etmelerine olanak tanıyan ve böylece kod enjeksiyonu riskini azaltan yeni bir genel yapılandırma bayrağı olan js.interpretation.enabled özelliğini getirmektedir.
Nasıl düzeltilir
- apache cloudstack4.20.2.0 ya da sonraki bir sürüm
Etkilenen ürünler
| Ürün | Etkilenen sürümler | Düzeltildiği sürüm |
|---|---|---|
| apache cloudstack | 4.18.0.0 ≤ v < 4.20.2.0, 4.21.0.0 | 4.20.2.0 |
Sürümünüzü kontrol edin
Ürünü seçin ve kullandığınız sürümü yazın; sürümün etkilenen aralıkta olup olmadığını görün.
Attack Surface Management
Alan adlarınıza bağlı varlıkları, bu varlıklarda çalışan teknolojileri ve bilinen zafiyetleri tek listede görün.