CVE-2026-55758
Açıklama
CC: Tweaked, Minecraft için oyuna programlanabilir bilgisayarlar, kaplumbağalar ve daha fazlasını ekleyen bir moddur. 1.120.0 sürümünden önce, projects/core/src/main/java/dan200/computercraft/core/apis/http/options/AddressPredicate.java dosyasındaki SSRF koruması, RFC 6052 64:ff9b::/96 NAT64 önekini engellemekte ancak RFC 8215 64:ff9b:1::/48 yerel kullanım öneğini atlamaktadır. RFC 8215 NAT64 kullanan çift yığınlı (dual-stack) bir sunucuda, Lua kodu çalıştırabilen kimliği doğrulanmamış bir kullanıcı; PrivatePattern.matches() eşlenen IPv6 adresini özel olarak sınıflandırmadığı için loopback, RFC 1918, bulut meta verileri veya dahili API uç noktalarına erişmek amacıyla 64:ff9b:1::/48 altındaki bir adresle http.request veya http.websocket kullanabilir. Bu sorun 1.120.0 sürümünde düzeltilmiştir.
Nasıl düzeltilir
Kaynaklarda bu zafiyet için düzeltilmiş sürüm ya da yama bağlantısı yok.
Etkilenen ürünler
| Ürün | Etkilenen sürümler | Düzeltildiği sürüm |
|---|---|---|
| cc-tweaked CC-Tweaked | < 1.120.0 | — |
Sürümünüzü kontrol edin
Ürünü seçin ve kullandığınız sürümü yazın; sürümün etkilenen aralıkta olup olmadığını görün.
Attack Surface Management
Alan adlarınıza bağlı varlıkları, bu varlıklarda çalışan teknolojileri ve bilinen zafiyetleri tek listede görün.