CVE-2026-9256

Yüksek

Açıklama

NGINX Plus ve NGINX Open Source, ngx_http_rewrite_module modülünde bir güvenlik açığına sahiptir. Bu açık; bir rewrite direktifi, farklı ve örtüşen Perl-Compatible Regular Expression (PCRE) yakalamaları içeren bir regex deseni (örneğin, ^/((.*))$) ve yönlendirme veya argümanlar bağlamında bu yakalamaların birden fazlasına referans veren bir değiştirme dizesi (örneğin, $1$2) kullandığında ortaya çıkar. Kimliği doğrulanmamış bir saldırgan, kontrolü dışındaki koşullarla birlikte, özel olarak hazırlanmış HTTP istekleri göndererek bu zafiyeti istismar edebilir. Bu durum, NGINX worker sürecinde yeniden başlatmaya yol açan bir heap buffer overflow oluşmasına neden olabilir. Ek olarak saldırganlar, Address Space Layout Randomization (ASLR) özelliğinin devre dışı olduğu sistemlerde veya ASLR'yi atlayabildikleri durumlarda kod çalıştırabilirler. Not: Teknik Destek Sonu (EoTS) aşamasına gelmiş yazılım sürümleri değerlendirilmemiştir.

ÖnemYüksek
CVSS8.1
İstismar olasılığı—
ÜrünF5 Nginx Open Source
Yayın22 May 2026
İlk görülme22 May 2026
Zayıflık türüCWE-122CWE-122

Nasıl düzeltilir

Güncelleyin
  • f5 nginx_open_source1.30.2 ya da sonraki bir sürüm
  • f5 nginx_plusr36 ya da sonraki bir sürüm
  • f5 nginx_gateway_fabric2.6.2 ya da sonraki bir sürüm
  • f5 nginx_ingress_controller5.4.3 ya da sonraki bir sürüm
  • f5 nginx_instance_manager2.22.1 ya da sonraki bir sürüm
  • redhat update_infrastructure5.2 ya da sonraki bir sürüm

Etkilenen ürünler

ÜrünEtkilenen sürümlerDüzeltildiği sürüm
f5 nginx_open_source0.1.17 ≤ v ≤ 0.9.7, 1.0.0 ≤ v < 1.30.2, 1.31.01.30.2
f5 nginx_plusr33 ≤ v < r36, 37.0.0.1, r32, r36r36
f5 dos4.3.0 ≤ v ≤ 4.7.0, 4.9.0—
f5 nginx_gateway_fabric1.3.0 ≤ v ≤ 1.6.2, 2.0.0 ≤ v < 2.6.22.6.2
f5 nginx_ingress_controller3.5.0 ≤ v ≤ 3.7.2, 4.0.0 ≤ v ≤ 4.0.1, 5.0.0 ≤ v < 5.4.35.4.3
f5 nginx_instance_manager2.17.0 ≤ v < 2.22.12.22.1
f5 waf4.10.0 ≤ v ≤ 4.16.0, 5.2.0 ≤ v ≤ 5.8.0, 5.9.0 ≤ v ≤ 5.13.0—
redhat discoveryAralık belirtilmemiş—
redhat hardened_imagesAralık belirtilmemiş—
redhat update_infrastructure5.0 ≤ v < 5.25.2
debian debian_linux11.0—
redhat enterprise_linux8.0, 9.0, 10.0—

Sürümünüzü kontrol edin

Ürünü seçin ve kullandığınız sürümü yazın; sürümün etkilenen aralıkta olup olmadığını görün.

Intelligence 360 paketinde

Attack Surface Management

Alan adlarınıza bağlı varlıkları, bu varlıklarda çalışan teknolojileri ve bilinen zafiyetleri tek listede görün.

CVE-2026-9256 · F5 Nginx Open Source · Dark Radar