CVE-2007-10003

Medium

Description

A vulnerability, which was classified as critical, has been found in The Hackers Diet Plugin up to 0.9.6b on WordPress. This issue affects some unknown processing of the file ajax_blurb.php of the component HTTP POST Request Handler. The manipulation of the argument user leads to sql injection. The attack may be initiated remotely. Upgrading to version 0.9.7b is able to address this issue. The patch is named 7dd8acf7cd8442609840037121074425d363b694. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-243803.

SeverityMedium
CVSS6.3
Exploit probability—
ProductWp-plugins The Hackers Diet
PublishedOct 29, 2023
First seenOct 29, 2023
Weakness typeCWE-89SQL injection

How to fix

Affected products

ProductAffected versionsFixed in
wp-plugins the_hackers_dietv < 0.9.7b0.9.7b

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.