CVE-2008-4456
Description
Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.
How to fix
Sources list no fixed version or patch link for this vulnerability.
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| mysql mysql | 5.0.4, 5.0.30, 5.0.36, 5.0.44 | — |
| oracle mysql | 5.0.26, 5.0.27, 5.0.30, 5.0.32, 5.0.33, 5.0.37, 5.0.38, 5.0.41, 5.0.42, 5.0.45, 5.0.67 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.