CVE-2010-10002

Low

Description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability classified as problematic has been found in SimpleSAMLphp simplesamlphp-module-openid. Affected is an unknown function of the file templates/consumer.php of the component OpenID Handler. The manipulation of the argument AuthState leads to cross site scripting. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.0 is able to address this issue. The patch is identified as d652d41ccaf8c45d5707e741c0c5d82a2365a9a3. It is recommended to upgrade the affected component. VDB-217170 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

SeverityLow
CVSS3.1
Exploit probability—
ProductSimplesamlphp-module-openid
PublishedJan 1, 2023
First seenJan 1, 2023

How to fix

Update
  • simplesamlphp simplesamlphp-module-openid1.0 or later
  • simplesamlphp/simplesamlphp-module-openid1.0 or later

Affected products

ProductAffected versionsFixed in
simplesamlphp simplesamlphp-module-openidv < 1.01.0
simplesamlphp/simplesamlphp-module-openidPackagistv < 1.01.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.