CVE-2012-1723

CriticalActively exploited (CISA KEV)Known to be used in ransomware campaigns

Description

Unspecified vulnerability in the Java Runtime Environment (JRE) component in Oracle Java SE 7 update 4 and earlier, 6 update 32 and earlier, 5 update 35 and earlier, and 1.4.2_37 and earlier allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors related to Hotspot.

SeverityCritical
CVSS9.8
Exploit probability—
ProductOracle Java SE
PublishedJun 16, 2012
First seenJun 16, 2012
Added to KEVMar 3, 2022

How to fix

CISA required action

Apply updates per vendor instructions.

CISA due date: Mar 24, 2022
Update
  • redhat icedtea61.10.8, 1.11.3 or later

Affected products

ProductAffected versionsFixed in
oracle jdkv ≤ 1.4.2_37, 1.5.0, 1.6.0, 1.7.0—
oracle jrev ≤ 1.4.2_37, 1.5.0, 1.6.0, 1.7.0—
redhat icedtea6v < 1.10.8, 1.11.0 ≤ v < 1.11.31.10.8, 1.11.3
redhat enterprise_linux_desktop5.0, 6.0—
redhat enterprise_linux_eus6.2—
redhat enterprise_linux_server5.0, 6.0—
redhat enterprise_linux_server_aus6.2—
redhat enterprise_linux_workstation5.0, 6.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.