CVE-2014-125051

Medium

Description

A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 is able to address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.

SeverityMedium
CVSS5.5
Exploit probability—
ProductYii2-jqgrid-widget
PublishedJan 6, 2023
First seenJan 6, 2023
Weakness typeCWE-89SQL injection

How to fix

Update
  • yii2-jqgrid-widget_project yii2-jqgrid-widget1.0.8 or later
  • himiklab/yii2-jqgrid-widget1.0.8 or later

Affected products

ProductAffected versionsFixed in
yii2-jqgrid-widget_project yii2-jqgrid-widgetv < 1.0.81.0.8
himiklab/yii2-jqgrid-widgetPackagistv < 1.0.81.0.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.