CVE-2014-125055

Low

Description

A vulnerability, which was classified as problematic, was found in agnivade easy-scrypt. Affected is the function VerifyPassphrase of the file scrypt.go. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.0.0 is able to address this issue. The name of the patch is 477c10cf3b144ddf96526aa09f5fdea613f21812. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217596.

SeverityLow
CVSS2.6
Exploit probability—
ProductEasy-script
PublishedJan 7, 2023
First seenJan 7, 2023
Weakness typeCWE-208CWE-208

How to fix

Update
  • easy-script_project easy-script1.0.0 or later
  • github.com/agnivade/easy-scrypt1.0.0 or later

Affected products

ProductAffected versionsFixed in
easy-script_project easy-scriptv < 1.0.01.0.0
github.com/agnivade/easy-scryptGov < 1.0.01.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.