CVE-2015-10030

Medium

Description

A vulnerability has been found in SUKOHI Surpass and classified as critical. This vulnerability affects unknown code of the file src/Sukohi/Surpass/Surpass.php. The manipulation of the argument dir leads to pathname traversal. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as d22337d453a2a14194cdb02bf12cdf9d9f827aa7. It is recommended to upgrade the affected component. VDB-217642 is the identifier assigned to this vulnerability.

SeverityMedium
CVSS5.5
Exploit probability—
ProductSurpass
PublishedJan 8, 2023
First seenJan 8, 2023
Weakness typeCWE-21CWE-21

How to fix

Update
  • surpass_project surpass1.0.0 or later
  • sukohi/surpass1.0.0 or later

Affected products

ProductAffected versionsFixed in
surpass_project surpassv < 1.0.01.0.0
sukohi/surpassPackagistv < 1.0.01.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2015-10030 · Surpass · Dark Radar