CVE-2015-10096

Medium

Description

A vulnerability, which was classified as critical, was found in Zarthus IRC Twitter Announcer Bot up to 1.1.0. This affects the function get_tweets of the file lib/twitterbot/plugins/twitter_announcer.rb. The manipulation of the argument tweet leads to command injection. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.1.1 is able to address this issue. The patch is named 6b1941b7fc2c70e1f40981b43c84a2c20cc12bd3. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-223383.

SeverityMedium
CVSS5.0
Exploit probability—
ProductIrc Twitter Announcer Bot
PublishedMar 20, 2023
First seenMar 20, 2023

How to fix

Affected products

ProductAffected versionsFixed in
irc_twitter_announcer_bot_project irc_twitter_announcer_bot1.0.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.