CVE-2015-10105

Medium

Description

A vulnerability, which was classified as critical, was found in IP Blacklist Cloud Plugin up to 3.42 on WordPress. This affects the function valid_js_identifier of the file ip_blacklist_cloud.php of the component CSV File Import. The manipulation of the argument filename leads to path traversal. It is possible to initiate the attack remotely. Upgrading to version 3.43 is able to address this issue. The identifier of the patch is 6e6fe8c6fda7cbc252eef083105e08d759c07312. It is recommended to upgrade the affected component. The identifier VDB-227757 was assigned to this vulnerability.

SeverityMedium
CVSS6.3
Exploit probability—
ProductAd33lx Ip Blacklist Cloud
PublishedMay 1, 2023
First seenMay 1, 2023

How to fix

Affected products

ProductAffected versionsFixed in
ad33lx ip_blacklist_cloudv ≤ 3.42—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2015-10105 · Ad33lx Ip Blacklist Cloud · Dark Radar