CVE-2015-5243
Critical
Description
phpWhois allows remote attackers to execute arbitrary code via a crafted whois record.
SeverityCritical
CVSS9.8
Exploit probability—
ProductPhpwhois
PublishedAug 20, 2018
First seenAug 20, 2018
How to fix
Update
- jsmitty12/phpwhois5.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| phpwhois_project phpwhois | v ≤ 4.2.2 | — |
| jsmitty12/phpwhoisPackagist | v < 5.1.0 | 5.1.0 |
| phpwhois/phpwhoisPackagist | v ≤ 4.2.5 | — |
| brightlocal/phpwhoisPackagist | v ≤ 4.2.5 | — |
| david-garcia/phpwhoisPackagist | v ≤ 4.3.1 | — |
| ivankristianto/phpwhoisPackagist | v ≤ 4.3.0 | — |
| kazist/phpwhoisPackagist | v ≤ 4.2.6 | — |
| serluck/phpwhoisPackagist | v ≤ 4.2.6 | — |
| simple-updates/phpwhoisPackagist | v ≤ 1.0.0 | — |
| truckersmp/phpwhoisPackagist | v ≤ 4.3.1 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.