CVE-2016-15015

Low

Description

A vulnerability, which was classified as problematic, was found in viafintech Barzahlen Payment Module PHP SDK up to 2.0.0. Affected is the function verify of the file src/Webhook.php. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 2.0.1 is able to address this issue. The patch is identified as 3e7d29dc0ca6c054a6d6e211f32dae89078594c1. It is recommended to upgrade the affected component. VDB-217650 is the identifier assigned to this vulnerability.

SeverityLow
CVSS2.6
Exploit probability—
ProductPaysafe Barzahlen Payment Module Php Sdk
PublishedJan 8, 2023
First seenJan 8, 2023
Weakness typeCWE-208CWE-208

How to fix

Update
  • paysafe barzahlen_payment_module_php_sdk2.0.1 or later
  • barzahlen/barzahlen-php2.0.1 or later

Affected products

ProductAffected versionsFixed in
paysafe barzahlen_payment_module_php_sdkv < 2.0.12.0.1
barzahlen/barzahlen-phpPackagistv < 2.0.12.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.