CVE-2016-15020

Medium

Description

A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The patch is named 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.

SeverityMedium
CVSS5.5
Exploit probability—
ProductLiftkit Database Library
PublishedJan 16, 2023
First seenJan 16, 2023
Weakness typeCWE-89SQL injection

How to fix

Update
  • liftkit_database_library_project liftkit_database_library2.13.2 or later
  • liftkit/database2.13.2 or later

Affected products

ProductAffected versionsFixed in
liftkit_database_library_project liftkit_database_libraryv < 2.13.22.13.2
liftkit/databasePackagistv < 2.13.22.13.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.