CVE-2017-12612
Description
In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.
How to fix
- org.apache.spark:spark-core_2.112.1.2 or later
- org.apache.spark:spark-core_2.102.1.2 or later
- pyspark2.1.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache spark | 1.6.0, 1.6.1, 1.6.2, 1.6.3, 2.0.0, 2.0.1, 2.0.2, 2.1.0, 2.1.1 | — |
| org.apache.spark:spark-core_2.11Maven | v < 2.1.2 | 2.1.2 |
| org.apache.spark:spark-core_2.10Maven | v < 2.1.2 | 2.1.2 |
| pysparkPyPI | v < 2.1.2 | 2.1.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.