CVE-2017-12614

Medium

Description

It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.

SeverityMedium
CVSS6.1
Exploit probability—
ProductApache Airflow
PublishedAug 6, 2018
First seenAug 6, 2018

How to fix

Update
  • apache airflow1.9.0 or later
  • apache-airflow1.9.0 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 1.9.01.9.0
apache-airflowPyPIv < 1.9.01.9.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.