CVE-2017-15655

Critical

Description

Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt version <=3.0.0.4.376.X. All have been fixed in version 3.0.0.4.378, but this vulnerability was not previously disclosed. Some end-of-life routers have this version as the newest and thus are vulnerable at this time. This vulnerability allows for RCE with administrator rights when the administrator visits several pages.

SeverityCritical
CVSS9.6
Exploit probability—
ProductAsuswrt
PublishedJan 31, 2018
First seenJan 31, 2018

How to fix

Update
  • asus asuswrt3.0.0.4.378 or later

Affected products

ProductAffected versionsFixed in
asus asuswrtv < 3.0.0.4.3783.0.0.4.378

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.