CVE-2017-15708
Description
In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.
How to fix
- org.apache.synapse:synapse-core3.0.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache synapse | 1.0, 1.1, 1.1.1, 1.1.2, 1.2, 2.0.0, 2.1.0, 3.0.0 | — |
| oracle financial_services_market_risk_measurement_and_management | 8.0.6, 8.0.8 | — |
| oracle peoplesoft_enterprise_peopletools | 8.56, 8.57 | — |
| org.apache.synapse:synapse-coreMaven | v < 3.0.1 | 3.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.