CVE-2017-16861
Description
It was possible for double OGNL evaluation in certain redirect action and in WebWork URL and Anchor tags in JSP files to occur. An attacker who can access the web interface of Fisheye or Crucible or who hosts a website that a user who can access the web interface of Fisheye or Crucible visits, is able to exploit this vulnerability to execute Java code of their choice on systems that run a vulnerable version of Fisheye or Crucible. All versions of Fisheye and Crucible before 4.4.5 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.2 (the fixed version for 4.5.x) are affected by this vulnerability.
How to fix
- atlassian fisheye4.4.5, 4.5.2 or later
- atlassian crucible4.4.5, 4.5.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| atlassian fisheye | v < 4.4.5, 4.5.0 ≤ v < 4.5.2 | 4.4.5, 4.5.2 |
| atlassian crucible | v < 4.4.5, 4.5.0 ≤ v < 4.5.2 | 4.4.5, 4.5.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.