CVE-2017-20157

Medium

Description

A vulnerability was found in Ariadne Component Library up to 2.x. It has been classified as critical. Affected is an unknown function of the file src/url/Url.php. The manipulation leads to server-side request forgery. Upgrading to version 3.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217140.

SeverityMedium
CVSS5.5
Exploit probability—
ProductAriadne-cms Ariadne Component Library
PublishedDec 31, 2022
First seenDec 31, 2022

How to fix

Affected products

ProductAffected versionsFixed in
ariadne-cms ariadne_component_libraryv < 3.03.0
arc/webPackagistv < 3.03.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2017-20157 · Ariadne-cms Ariadne Component Library · Dark Radar