CVE-2017-20165
Description
A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x. This affects the function useColors of the file src/node.js. The manipulation of the argument str leads to inefficient regular expression complexity. Upgrading to version 3.1.0 is able to address this issue. The identifier of the patch is c38a0166c266a679c8de012d4eaccec3f944e685. It is recommended to upgrade the affected component. The identifier VDB-217665 was assigned to this vulnerability.
How to fix
- debug_project debug2.6.9, 3.1.0 or later
- debug3.1.0, 2.6.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| debug_project debug | v < 2.6.9, 3.0.0 ≤ v < 3.1.0 | 2.6.9, 3.1.0 |
| debugnpm | 3.0.0 ≤ v < 3.1.0, v < 2.6.9 | 3.1.0, 2.6.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.