CVE-2017-20175

Low

Description

A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2 on MediaWiki. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The patch is named 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.

SeverityLow
CVSS2.6
Exploit probability—
ProductMediawiki Matomo
PublishedFeb 5, 2023
First seenFeb 5, 2023

How to fix

Affected products

ProductAffected versionsFixed in
mediawiki matomo2.4.0 ≤ v < 2.4.32.4.3
mediawiki/matomoPackagistv < 2.4.32.4.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.