CVE-2017-5637

High

Description

Two four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Zookeeper
PublishedOct 10, 2017
First seenOct 10, 2017

How to fix

Affected products

ProductAffected versionsFixed in
apache zookeeper3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.4.8, 3.4.9, 3.5.0, 3.5.1, 3.5.2—
debian debian_linux8.0—
org.apache.zookeeper:zookeeperMaven3.4.0 ≤ v < 3.4.10, 3.5.0 ≤ v < 3.5.33.4.10, 3.5.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.