CVE-2017-7241
Description
A cross-site scripting (XSS) vulnerability in the MantisBT Move Attachments page (move_attachments_page.php, part of admin tools) allows remote attackers to inject arbitrary code through a crafted 'type' parameter, if Content Security Protection (CSP) settings allows it. This is fixed in 1.3.9, 2.1.3, and 2.2.3. Note that this vulnerability is not exploitable if the admin tools directory is removed, as recommended in the "Post-installation and upgrade tasks" of the MantisBT Admin Guide. A reminder to do so is also displayed on the login page.
How to fix
- mantisbt/mantisbt1.3.9, 2.1.3, 2.2.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| mantisbt mantisbt | 1.2.16, 1.2.17, 1.2.18, 1.2.19, 1.2.20, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.3.8, 1.3.9, 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0 | — |
| mantisbt/mantisbtPackagist | v < 1.3.9, 2.0.0 ≤ v < 2.1.3, 2.2.0 ≤ v < 2.2.3 | 1.3.9, 2.1.3, 2.2.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.