CVE-2017-7297
High
Description
Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Suse Rancher
PublishedMar 29, 2017
First seenMar 29, 2017
How to fix
Update
- suse rancher1.2.4, 1.3.5, 1.4.3, 1.5.3 or later
- github.com/rancher/rancher1.5.3, 1.4.3, 1.3.5, 1.2.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| suse rancher | 1.2.0 ≤ v < 1.2.4, 1.3.0 ≤ v < 1.3.5, 1.4.0 ≤ v < 1.4.3, 1.5.0 ≤ v < 1.5.3 | 1.2.4, 1.3.5, 1.4.3, 1.5.3 |
| github.com/rancher/rancherGo | 1.5.0 ≤ v < 1.5.3, 1.4.0 ≤ v < 1.4.3, 1.3.0 ≤ v < 1.3.5, 1.2.0 ≤ v < 1.2.4 | 1.5.3, 1.4.3, 1.3.5, 1.2.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.