CVE-2018-1000024

High

Description

The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can result in Denial of Service for all clients using the proxy.. This attack appear to be exploitable via Remote server delivers an HTTP response payload containing valid but unusual ESI syntax.. This vulnerability appears to have been fixed in 4.0.23 and later.

SeverityHigh
CVSS7.5
Exploit probability95. percentile7.9%
ProductSquid
PublishedFeb 9, 2018
First seenFeb 9, 2018

How to fix

Affected products

ProductAffected versionsFixed in
squid-cache squid3.0 ≤ v ≤ 3.5.27, 4.0 ≤ v ≤ 4.0.22—
debian debian_linux7.0, 8.0, 9.0—
canonical ubuntu_linux14.04, 16.04, 17.10—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.