CVE-2018-1000025

High

Description

Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.

SeverityHigh
CVSS8.1
Exploit probability—
ProductFirebase Admin Sdk For Php
PublishedFeb 9, 2018
First seenFeb 9, 2018

How to fix

Update
  • kreait/firebase-php3.8.1 or later

Affected products

ProductAffected versionsFixed in
firebase_admin_sdk_for_php_project firebase_admin_sdk_for_php3.2.0 ≤ v ≤ 3.8.0—
kreait/firebase-phpPackagist3.2.0 ≤ v < 3.8.13.8.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.