CVE-2018-1000078

Medium

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.

SeverityMedium
CVSS6.1
Exploit probability—
ProductRubygems
PublishedMar 13, 2018
First seenMar 13, 2018

How to fix

Affected products

ProductAffected versionsFixed in
rubygems rubygemsv ≤ 2.2.9, v ≤ 2.3.6, v ≤ 2.4.3, v ≤ 2.5.0—
debian debian_linux7.0—
rubygems-updateRubyGemsv < 2.7.62.7.6
org.jruby:jruby-stdlibMavenv < 9.1.16.09.1.16.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.