CVE-2018-1000079
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.
How to fix
- rubygems-update2.7.6 or later
- org.jruby:jruby-stdlib9.1.16.0 or later
- debian.org/security/2018/dsa-4219
- usn.ubuntu.com/3621-1/
- access.redhat.com/errata/RHSA-2018:3729
- access.redhat.com/errata/RHSA-2018:3730
- access.redhat.com/errata/RHSA-2018:3731
- debian.org/security/2018/dsa-4259
- access.redhat.com/errata/RHSA-2019:2028
- access.redhat.com/errata/RHSA-2020:0542
- access.redhat.com/errata/RHSA-2020:0591
- access.redhat.com/errata/RHSA-2020:0663
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| rubygems rubygems | v ≤ 2.2.9, v ≤ 2.3.6, v ≤ 2.4.3, v ≤ 2.5.0 | — |
| rubygems-updateRubyGems | v < 2.7.6 | 2.7.6 |
| org.jruby:jruby-stdlibMaven | v < 9.1.16.0 | 9.1.16.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.