CVE-2018-1000086
Description
NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.
How to fix
- pym.js1.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| npr pym.js | 0.4.2 ≤ v ≤ 1.3.1 | — |
| pym.jsnpm | 0.4.2 ≤ v < 1.3.2 | 1.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.