CVE-2018-1000127

High

Description

memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.

SeverityHigh
CVSS7.5
Exploit probability—
ProductMemcached
PublishedMar 13, 2018
First seenMar 13, 2018

How to fix

Affected products

ProductAffected versionsFixed in
memcached memcachedv < 1.4.371.4.37
debian debian_linux7.0, 8.0, 9.0—
canonical ubuntu_linux14.04, 16.04, 17.10—
redhat openstack10—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.