CVE-2018-1000132
Critical
Description
Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Mercurial
PublishedMar 14, 2018
First seenMar 14, 2018
How to fix
Update
- mercurial mercurial4.5.1 or later
- mercurial4.5.1 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| mercurial mercurial | v < 4.5.1 | 4.5.1 |
| debian debian_linux | 7.0, 8.0 | — |
| mercurialPyPI | v < 4.5.1 | 4.5.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.