CVE-2018-1000136
Description
Electron version 1.7 up to 1.7.12; 1.8 up to 1.8.3 and 2.0.0 up to 2.0.0-beta.3 contains an improper handling of values vulnerability in Webviews that can result in remote code execution. This attack appear to be exploitable via an app which allows execution of 3rd party code AND disallows node integration AND has not specified if webview is enabled/disabled. This vulnerability appears to have been fixed in 1.7.13, 1.8.4, 2.0.0-beta.4.
How to fix
- electron1.7.13, 1.8.4, 2.0.0-beta.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| electronjs electron | 1.7.0 ≤ v ≤ 1.7.12, 1.8.0 < v ≤ 1.8.3, 2.0.0 | — |
| electronnpm | 1.7.0 ≤ v < 1.7.13, 1.8.0 ≤ v < 1.8.4, 2.0.0-beta.1 ≤ v < 2.0.0-beta.5 | 1.7.13, 1.8.4, 2.0.0-beta.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.