CVE-2018-1000162

Medium

Description

Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in `setMarkupEscaped` for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.

SeverityMedium
CVSS6.1
Exploit probability—
ProductParsedown
PublishedApr 18, 2018
First seenApr 18, 2018

How to fix

Update
  • parsedown parsedown1.7.0 or later
  • erusev/parsedown1.7.0 or later

Affected products

ProductAffected versionsFixed in
parsedown parsedownv < 1.7.01.7.0
erusev/parsedownPackagistv < 1.7.01.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.