CVE-2018-1000165

High

Description

LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in signature validation in readers in src/LightSaml/Model/XmlDSig/ that can result in impersonation of any user from Identity Provider. This vulnerability appears to have been fixed in 1.3.5 and later.

SeverityHigh
CVSS7.5
Exploit probability—
ProductLightsaml
PublishedApr 18, 2018
First seenApr 18, 2018

How to fix

Update
  • lightsaml lightsaml1.3.5 or later
  • lightsaml/lightsaml1.3.5 or later

Affected products

ProductAffected versionsFixed in
lightsaml lightsamlv < 1.3.51.3.5
lightsaml/lightsamlPackagistv < 1.3.51.3.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.