CVE-2018-1000216

High

Description

Dave Gamble cJSON version 1.7.2 and earlier contains a CWE-415: Double Free vulnerability in cJSON library that can result in Possible crash or RCE. This attack appear to be exploitable via Attacker must be able to force victim to print JSON data, depending on how cJSON library is used this could be either local or over a network. This vulnerability appears to have been fixed in 1.7.3.

SeverityHigh
CVSS8.8
Exploit probability—
ProductDavegamble Cjson
PublishedAug 20, 2018
First seenAug 20, 2018

How to fix

Update
  • davegamble cjson1.7.3 or later

Affected products

ProductAffected versionsFixed in
davegamble cjsonv < 1.7.31.7.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.