CVE-2018-1000301

Critical

Description

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

SeverityCritical
CVSS9.1
Exploit probability93. percentile5.8%
ProductHaxx Curl
PublishedMay 24, 2018
First seenMay 24, 2018

How to fix

Affected products

ProductAffected versionsFixed in
haxx curl7.20.0 ≤ v ≤ 7.59.0—
debian debian_linux7.0, 8.0, 9.0—
canonical ubuntu_linux12.04, 14.04, 16.04, 17.10, 18.04—
redhat enterprise_linux_desktop7.0—
redhat enterprise_linux_server7.0—
redhat enterprise_linux_workstation7.0—
oracle communications_webrtc_session_controllerv < 7.27.2
oracle enterprise_manager_ops_center12.2.2, 12.3.3—
oracle peoplesoft_enterprise_peopletools8.55, 8.56, 8.57—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.