CVE-2018-1000401

High

Description

Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.

SeverityHigh
CVSS7.8
Exploit probability—
ProductJenkins Aws Codepipeline
PublishedJul 9, 2018
First seenJul 9, 2018

How to fix

Update
  • com.amazonaws:aws-codepipeline0.37 or later

Affected products

ProductAffected versionsFixed in
jenkins aws_codepipelinev ≤ 0.36—
com.amazonaws:aws-codepipelineMavenv < 0.370.37

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.