CVE-2018-1000403
High
Description
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 1.20 and later.
SeverityHigh
CVSS7.8
Exploit probability—
Product
Jenkins Aws Codedeploy
PublishedJul 9, 2018
First seenJul 9, 2018
How to fix
Update
- com.amazonaws:codedeploy1.20 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| jenkins aws_codedeploy | v ≤ 1.19 | — |
| com.amazonaws:codedeployMaven | v < 1.20 | 1.20 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.