CVE-2018-1000404

High

Description

Jenkins project Jenkins AWS CodeBuild Plugin version 0.26 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSClientFactory.java, CodeBuilder.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.27 and later.

SeverityHigh
CVSS7.8
Exploit probability—
ProductJenkins Aws Codebuild
PublishedJul 9, 2018
First seenJul 9, 2018

How to fix

Update
  • com.amazonaws:aws-codebuild0.27 or later

Affected products

ProductAffected versionsFixed in
jenkins aws_codebuildv ≤ 0.26—
com.amazonaws:aws-codebuildMavenv < 0.270.27

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.