CVE-2018-1000807
Description
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
How to fix
- pyopenssl pyopenssl17.5.0 or later
- pyopenssl17.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| pyopenssl pyopenssl | v < 17.5.0 | 17.5.0 |
| canonical ubuntu_linux | 16.04 | — |
| redhat openstack | 13 | — |
| redhat enterprise_linux_desktop | 7.0 | — |
| redhat enterprise_linux_server | 7.0 | — |
| redhat enterprise_linux_workstation | 7.0 | — |
| pyopensslPyPI | v < 17.5.0 | 17.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.