CVE-2018-1000817
Description
Asset Pipeline Grails Plugin Asset-pipeline plugin version Prior to 2.14.1.1, 2.15.1 and 3.0.6 contains a Incorrect Access Control vulnerability in Applications deployed in Jetty that can result in Download .class files and any arbitrary file. This attack appear to be exploitable via Specially crafted GET request containing directory traversal from assets-pipeline context. This vulnerability appears to have been fixed in 2.14.1.1 (for Grails 2.x), 2.15.1 (for Grails 3 and Java 7) and 3.0.6 (for Grails 3 and Java 8).
How to fix
- asset_pipeline_project asset-pipeline2.14.1.1, 2.15.1, 3.0.6 or later
- org.grails.plugins:asset-pipeline2.14.1, 2.15.1, 3.0.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| asset_pipeline_project asset-pipeline | v < 2.14.1.1, 2.14.1.1 < v < 2.15.1, 2.15.1 < v < 3.0.6 | 2.14.1.1, 2.15.1, 3.0.6 |
| org.grails.plugins:asset-pipelineMaven | v < 2.14.1, 2.15.0 ≤ v < 2.15.1, 3.0.0 ≤ v < 3.0.6 | 2.14.1, 2.15.1, 3.0.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.