CVE-2018-10499

High

Description

This vulnerability allows local attackers to execute arbitrary code on vulnerable installations of Samsung Galaxy Apps Fixed in version 6.4.0.15. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the handling of URLs. The issue lies in the lack of proper validation of user-supplied data, which can allow arbitrary JavaScript to execute. An attacker can leverage this vulnerability to install applications under the context of the current user. Was ZDI-CAN-5330.

SeverityHigh
CVSS7.0
Exploit probability—
ProductSamsung Galaxy Apps
PublishedSep 24, 2018
First seenSep 24, 2018

How to fix

Update
  • samsung galaxy_apps6.4.0.15 or later

Affected products

ProductAffected versionsFixed in
samsung galaxy_appsv < 6.4.0.156.4.0.15

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.